using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"<hr />(.*)<hr />";
        string input = @"<hr />sadasdasdsad<hr/>dsads adsa sad       <hr />sdsadsadsads<hr />";
        
        Match m = Regex.Match(input, pattern);
        Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
    }
}