Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
((?:(?(?=(e.g.|z.b.|Figs?\.|\d+\.\d))\2|[^.!?])+[.!?]))
/
gi
Input 1
1
New
Test 10. Testing. Testing. Fig. 20. The decimal 20.3 should 20 still be sentence.Ok now. try 2.3. Explained reference to Figs. 2 and 3.