$re = '/\b(?:(?![l])[a-z])+\b/m';
$str = 'asdasd asdasdlsadsad asdsad asd asd asdlasdsad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);