#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "-?\b\d+(?:\.\d+)?(?:/\d+(?:\.\d+)?)?\b"
Local $sString = "3.1/2.6" & @CRLF & _
"1.00/5.00" & @CRLF & _
"12/19" & @CRLF & _
"125" & @CRLF & _
"12.34" & @CRLF & _
"-567.89"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")