using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-?\b\d+(?:\.\d+)?(?:/\d+(?:\.\d+)?)?\b";
string input = @"3.1/2.6
1.00/5.00
12/19
125
12.34
-567.89";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}