import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\([^()]*\\)[[:blank:]][[:blank:]]*)[^()]*\\([^()]*\\.([^()]*)\\)";
final String string = "TREE(abc/x73/APPLE) DEST(MYFILE.FILE1A) \n"
+ "TREE(abc/x74/APPLE) DEST(MYFILE88.FILE1A) \n"
+ "TREE(abc/x100/APPLE) DEST(MYFILE100.FILE1B) \n"
+ "TREE(abc/x61/APPLE) DEST(MYFILE1000.FILE1A)";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}