const regex = /(\([^()]*\)[[:blank:]][[:blank:]]*)[^()]*\([^()]*\.([^()]*)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\([^()]*\\)[[:blank:]][[:blank:]]*)[^()]*\\([^()]*\\.([^()]*)\\)', 'gm')
const str = `TREE(abc/x73/APPLE) DEST(MYFILE.FILE1A)
TREE(abc/x74/APPLE) DEST(MYFILE88.FILE1A)
TREE(abc/x100/APPLE) DEST(MYFILE100.FILE1B)
TREE(abc/x61/APPLE) DEST(MYFILE1000.FILE1A)`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);