// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\([^()]*\)[[:blank:]][[:blank:]]*)[^()]*\([^()]*\.([^()]*)\)").unwrap();
let string = "TREE(abc/x73/APPLE) DEST(MYFILE.FILE1A)
TREE(abc/x74/APPLE) DEST(MYFILE88.FILE1A)
TREE(abc/x100/APPLE) DEST(MYFILE100.FILE1B)
TREE(abc/x61/APPLE) DEST(MYFILE1000.FILE1A)";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}