const regex = new RegExp('[a-zA-Z ]+', 'gm')
const str = `日本語フレーズ A Japanese phrase A Japanese phrase 日本語フレーズ`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);