use strict;
my $str = '日本語フレーズ A Japanese phrase A Japanese phrase 日本語フレーズ';
my $regex = qr/[a-zA-Z ]+/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";