using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+\bcc\b|\bcc\b\s+";
string substitution = @"";
string input = @"aaa1234 cc bbb1234 c1234 cc dd aacc cccc ccadf cc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}