package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+:\S*`)
var str = `tag:value something alone: and other:tag :value
try /\S*:\S*/g and see the difference!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}