// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\[[^\]\[]*)70").unwrap();
let string = "filter [70.00-140.00]";
let substitution = "\\180";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}