$re = '/(?:RGB:|\G(?!^))[,\s]*(\d+)/m';
$str = 'RGB: 123, 12, 5
HSV: 23, 119, 223
7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);