import re
regex = re.compile(r"(?:https?:?\/?\/?)?(\d+)[\.:](\d+)[\.:](\d+)[\.:](\d+)(?::\d+)?")
test_str = ("194.58.120.176\n"
"http://194.58.120.176\n"
"https://194.58.120.176:80\n"
"https://194.58.120.176:443\n"
"194.58:120:176\n"
"194.58.120.176.1321")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")