$re = '/^[0-9](?:\.[0-9]{1,2})?$/';
$str = '1.23
0.00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);