using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\h*(?:RE|FW|FWD):)*)(.*)";
string input = @"RE: RE:RE: RE:FW: FWD: re: Dit is een email over software re: asdf ";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}