$re = '/#([^,\s]+)#/';
$str = '"Items:#1 #1000#,#2000#"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);