// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^-\s].*\n(-\s+[^\s-].*(?:\n-\s+[^\s-].*)*)").unwrap();
let string = "some text
- list
- list
- list
more text
- another list
- another list
- another list
more text
- another list
- -
- another list
more text
- another list
-
- another list";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}