package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\([-+]?0*[1-9]+,[-+]?0+[1-9]+\),)`)
var str = `(01,03),(+1,00003),`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}