$re = '~\G(?:, | ?/ ?)?\K[\w-]+~';
$str = 'Wodka/Rum, Gin / Bourbon eigen sich prima für Mixgetränke.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);