package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#([^\b#,() ]*)\b`)
var str = `#hot#hot hot #hot #hot.hot #hót #hot_hot #hot, (#hot) #hot. hot`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}