#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:<td[^<]*>|\G(?!^))(?:<[^<]+>)?(?!\s+)([^<]*)(?:<[^<]+>)?"
Local $sString = "<table class="fiche_table_caracter"><tbody>" & @CRLF & _
"<tr>" & @CRLF & _
" <td class="caracteristique"><strong>Design</strong></td>" & @CRLF & _
" <td>Classique (full tactile)</td>" & @CRLF & _
"</tr>" & @CRLF & _
"" & @CRLF & _
"<tr>" & @CRLF & _
" <td class="caracteristique"><strong>Système d'exploitation (OS)</strong></td>" & @CRLF & _
" <td>iOS</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
" <td class="caracteristique"><strong>Ecran</strong></td>" & @CRLF & _
" <td>4,7'' (1334 x 750 pixels)<br />16 millions de couleurs</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
" <td class="caracteristique"><strong>Mémoire interne</strong></td>" & @CRLF & _
" <td>128 Go, 1 Go RAM</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
" <td class="caracteristique"><strong>Appareil photo</strong></td>" & @CRLF & _
" <td>8 mégapixels</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")