$re = '/(.*)((core\/)?\/misc\/drupal\.js)/';
$str = 'installations/si/drupal-4test/misc/drupal.js
installations/si/drupal-8.1.0/core/misc/drupal.js
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);