re = /(?:^|\s)ThisPass\+(?=\s|$)/
str = 'Test for ThisPass++ Test for ThisPass ThisPass+ ThisPass, ThisPass; ThisPass.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end