package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:[1-4](?:\.\d{1,3})?)|(?:5(?:\.0{1,3})?)|(?:0\.(?:(?:(?:[1-9]\d{0,2}))|(?:0[1-9]\d?)|(?:00[1-9]))))$`)
var str = `5.000
4.891
0.001
0.9
2.1
3
0.111
0.000
0
5.101
6
4.1011`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}