import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[1-4](?:\\.\\d{1,3})?)|(?:5(?:\\.0{1,3})?)|(?:0\\.(?:(?:(?:[1-9]\\d{0,2}))|(?:0[1-9]\\d?)|(?:00[1-9]))))$";
final String string = "5.000\n"
+ "4.891\n"
+ "0.001\n"
+ "0.9\n"
+ "2.1\n"
+ "3\n"
+ "0.111\n"
+ "0.000\n"
+ "0\n"
+ "5.101\n"
+ "6\n"
+ "4.1011";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}