$re = '/^(?!.*love).*fruit/m';
$str = 'We all love green fruit.
-> dont match
We all love to walk.
-> dont match
We all green fruit.
-> match
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);