$re = '/^[a-zA-Z._\'~,-]+(?: +[a-zA-Z._\'~,-]+)*$/m';
$str = 'San Jose
Miami
El Doral
San Jose
SanJose
San Jose
San Bernardino
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);