re = /^[a-zA-Z._'~,-]+(?: +[a-zA-Z._'~,-]+)*$/m
str = 'San Jose
Miami
El Doral
San Jose
SanJose
San Jose
San Bernardino
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end