// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z._'~,-]+(?: +[a-zA-Z._'~,-]+)*$").unwrap();
let string = "San Jose
Miami
El Doral
San Jose
SanJose
San Jose
San Bernardino
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}