$re = '/(?|"((?:(?!",).)*)"|\h*([^,"]+))/';
$str = '"A", "B", "C - "G"", "D, F", 5, "A", "B", "C - "G"", "D,F,"G"F,Z,K", "A", "B", "C - "G"", "B", "C - "G"", "D,F,"G"F,Z,K", 1,"A",5, A,"D,8"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);