using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\[(!\[.+?\]\(.+?\)|.+?)]\(((https|http):\/\/[^\)]+)\))";
string input = @"#Regex for images and links
## Links
[example 1](https://example.com)
This [link](https://example2.com) is inline
## Images


[](http://link.com)";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}