import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\[(!\\[.+?\\]\\(.+?\\)|.+?)]\\(((https|http):\\/\\/[^\\)]+)\\))";
final String string = "#Regex for images and links\n\n"
+ "## Links\n\n"
+ "[example 1](https://example.com)\n"
+ "This [link](https://example2.com) is inline\n\n"
+ "## Images\n\n"
+ "\n"
+ "\n"
+ "[](http://link.com)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}