import Foundation
let pattern = #"(?=\[(!\[.+?\]\(.+?\)|.+?)]\(((https|http):\/\/[^\)]+)\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ###"""
#Regex for images and links
## Links
[example 1](https://example.com)
This [link](https://example2.com) is inline
## Images


[](http://link.com)
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)