import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://(www\\.|m\\.)?(reddit\\.com|preview\\.redd\\.it|i\\.redd\\.it|redd\\.it)/(((?!([\\\"'<])).)*)";
final String string = "https://reddit.com/r/lorem\n"
+ "https://preview.redd.it/r/ipsum\n"
+ "https://i.redd.it/r/dolor\n"
+ "https://redd.it/r/sit\n"
+ "https://www.reddit.com/r/lorem↵\n"
+ "https://www.preview.redd.it/r/ipsum↵\n"
+ "https://www.i.redd.it/r/dolor↵\n"
+ "https://www.redd.it/r/sit\n"
+ "https://m.reddit.com/r/lorem↵\n"
+ "https://m.preview.redd.it/r/ipsum↵\n"
+ "https://m.i.redd.it/r/dolor↵\n"
+ "https://m.redd.it/r/sit\n"
+ "https://no-reddit.com/r/lorem\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}