import Foundation
let pattern = #"https?://(www\.|m\.)?(reddit\.com|preview\.redd\.it|i\.redd\.it|redd\.it)/(((?!([\"'<])).)*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://reddit.com/r/lorem
https://preview.redd.it/r/ipsum
https://i.redd.it/r/dolor
https://redd.it/r/sit
https://www.reddit.com/r/lorem↵
https://www.preview.redd.it/r/ipsum↵
https://www.i.redd.it/r/dolor↵
https://www.redd.it/r/sit
https://m.reddit.com/r/lorem↵
https://m.preview.redd.it/r/ipsum↵
https://m.i.redd.it/r/dolor↵
https://m.redd.it/r/sit
https://no-reddit.com/r/lorem
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)