$re = '/^(0[0-9]|1[0-9]|2[1-4]):(0[0-9]|[1-5][0-9]):(0[0-9]|[1-5][0-9])$/m';
$str = '19:45:54
99:45:54
00:45:54
:45:54
19:45:99
09:07:01
19:99:54
25:45:54
// You can show origina post on albertcolom.com/blog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);