const regex = /((\\x[\d]{2}){4,}.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\\\x[\\d]{2}){4,}.*)', 'gm')
const str = `"\\x01\\x00\\x00\\x00\\x05\\x00\\x00\\x00\\x00\\x00\\x00\\x00X\\x1D›¿\\x04\\x04›?‹„\\x12¿Ã’\\x11?"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}