re = /((\\x[\d]{2}){4,}.*)/m
str = '"\\x01\\x00\\x00\\x00\\x05\\x00\\x00\\x00\\x00\\x00\\x00\\x00X\\x1D›¿\\x04\\x04›?‹„\\x12¿Ã’\\x11?"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end