# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<= |^)(\S+)(?: \1){2,}/\1 \1/gm;t' <<< "he he hemisphere
hi- hi- hi-tech"