#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<= |^)(\S+)(?: \1){2,}"
Local $sString = "he he hemisphere" & @CRLF & _
"hi- hi- hi-tech"
Local $sSubst = "\1 \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)