const regex = new RegExp('(?<= |^)(\\S+)(?: \\1){2,}', 'gm')
const str = `he he hemisphere
hi- hi- hi-tech`;
const subst = `\1 \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);