use strict;
my $str = 'he he hemisphere
hi- hi- hi-tech';
my $regex = qr/(?<= |^)(\S+)(?: \1){2,}/mp;
my $subst = '\\1 \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";