$re = '/(?<= |^)(\S+)(?: \1){2,}/m';
$str = 'he he hemisphere
hi- hi- hi-tech';
$subst = "\1 \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;