import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(0x[\\da-fA-F]+|[\\d]+|0b[01]+)\\b";
final String string = "1234 (decimal)\n"
+ "0x12CD (hex)\n"
+ "0x12cd (hex lowercase)\n"
+ "12CD (hex without the 0x prefix)\n"
+ "0b0010101011\n"
+ "0bh24j";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}