re = /\b(0x[\da-fA-F]+|[\d]+|0b[01]+)\b/
str = '1234 (decimal)
0x12CD (hex)
0x12cd (hex lowercase)
12CD (hex without the 0x prefix)
0b0010101011
0bh24j'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end