// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(0x[\da-fA-F]+|[\d]+|0b[01]+)\b").unwrap();
let string = "1234 (decimal)
0x12CD (hex)
0x12cd (hex lowercase)
12CD (hex without the 0x prefix)
0b0010101011
0bh24j";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}