// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z,a-z]{3}-[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}|^[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}$").unwrap();
let string = "FA12-BSE-008";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}