using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^lease.*(\n)*{$";
string substitution = @"\\$0";
string input = @"lease 192.168.0.1
{
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}